ppsspp-git 1.0.1.r2617.cf0697e-1
This commit is contained in:
parent
e9324589df
commit
5254854055
6
.SRCINFO
6
.SRCINFO
|
@ -1,6 +1,6 @@
|
|||
pkgbase = ppsspp-git
|
||||
pkgdesc = A PSP emulator written in C++
|
||||
pkgver = 1.0.1.r599.0597b92
|
||||
pkgver = 1.0.1.r2617.cf0697e
|
||||
pkgrel = 1
|
||||
url = http://www.ppsspp.org/
|
||||
arch = i686
|
||||
|
@ -14,14 +14,10 @@ pkgbase = ppsspp-git
|
|||
depends = sdl2
|
||||
source = git+https://github.com/hrydgard/ppsspp.git
|
||||
source = git+https://github.com/hrydgard/ppsspp-lang.git
|
||||
source = ppsspp-native::git+https://github.com/hrydgard/native.git
|
||||
source = ppsspp-armips::git+https://github.com/Kingcom/armips.git
|
||||
source = ppsspp-gcc5.1.patch
|
||||
sha256sums = SKIP
|
||||
sha256sums = SKIP
|
||||
sha256sums = SKIP
|
||||
sha256sums = SKIP
|
||||
sha256sums = 719f6ae3efa533872f1db5131bc9e7245d7c2e40e776c9869a0820be17f0ac9d
|
||||
|
||||
pkgname = ppsspp-git
|
||||
provides = ppsspp
|
||||
|
|
35
PKGBUILD
35
PKGBUILD
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgbase=ppsspp-git
|
||||
pkgname=('ppsspp-git' 'ppsspp-qt-git')
|
||||
pkgver=1.0.1.r599.0597b92
|
||||
pkgver=1.0.1.r2617.cf0697e
|
||||
pkgrel=1
|
||||
pkgdesc='A PSP emulator written in C++'
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -17,14 +17,10 @@ depends=('ffmpeg' 'sdl2')
|
|||
makedepends=('cmake' 'git' 'glu' 'qt5-tools')
|
||||
source=('git+https://github.com/hrydgard/ppsspp.git'
|
||||
'git+https://github.com/hrydgard/ppsspp-lang.git'
|
||||
'ppsspp-native::git+https://github.com/hrydgard/native.git'
|
||||
'ppsspp-armips::git+https://github.com/Kingcom/armips.git'
|
||||
'ppsspp-gcc5.1.patch')
|
||||
'ppsspp-armips::git+https://github.com/Kingcom/armips.git')
|
||||
sha256sums=('SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'719f6ae3efa533872f1db5131bc9e7245d7c2e40e776c9869a0820be17f0ac9d')
|
||||
'SKIP')
|
||||
|
||||
pkgver() {
|
||||
cd ppsspp
|
||||
|
@ -35,22 +31,22 @@ pkgver() {
|
|||
prepare() {
|
||||
cd ppsspp
|
||||
|
||||
for submodule in native lang ext/armips; do
|
||||
for submodule in lang ext/armips; do
|
||||
git submodule init ${submodule}
|
||||
git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
|
||||
git submodule update ${submodule}
|
||||
done
|
||||
|
||||
patch -Np1 -i ../ppsspp-gcc5.1.patch
|
||||
for ui in sdl qt; do
|
||||
if [[ -d build-$ui ]]; then
|
||||
rm -rf build-$ui
|
||||
fi
|
||||
mkdir build-$ui
|
||||
done
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ppsspp
|
||||
|
||||
if [[ -d build ]]; then
|
||||
rm -rf build
|
||||
fi
|
||||
mkdir build && cd build
|
||||
cd ppsspp/build-sdl
|
||||
|
||||
cmake .. \
|
||||
-DCMAKE_BUILD_TYPE='Release' \
|
||||
|
@ -58,12 +54,7 @@ build() {
|
|||
-DUSE_SYSTEM_FFMPEG='TRUE'
|
||||
make
|
||||
|
||||
cd ..
|
||||
|
||||
if [[ -d build-qt ]]; then
|
||||
rm -rf build-qt
|
||||
fi
|
||||
mkdir build-qt && cd build-qt
|
||||
cd ../build-qt
|
||||
|
||||
qmake-qt5 CONFIG+='release' CONFIG+='system_ffmpeg' ../Qt/PPSSPPQt.pro
|
||||
make
|
||||
|
@ -73,7 +64,7 @@ package_ppsspp-git() {
|
|||
provides=('ppsspp')
|
||||
conflicts=('ppsspp' 'ppsspp-qt' 'ppsspp-qt-git')
|
||||
|
||||
cd ppsspp/build
|
||||
cd ppsspp/build-sdl
|
||||
|
||||
install -dm 755 "${pkgdir}"/usr/{bin,share/{applications,man/man1,pixmaps,ppsspp}}
|
||||
install -m 755 PPSSPPSDL "${pkgdir}"/usr/bin/ppsspp
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
diff -rupN ppsspp.orig/ext/xbrz/xbrz.cpp ppsspp/ext/xbrz/xbrz.cpp
|
||||
--- ppsspp.orig/ext/xbrz/xbrz.cpp 2015-06-01 14:16:20.005738417 +0200
|
||||
+++ ppsspp/ext/xbrz/xbrz.cpp 2015-06-01 14:21:30.365765974 +0200
|
||||
@@ -648,23 +648,21 @@ void scalePixel(const Kernel_3x3& ker,
|
||||
auto eq = [&](uint32_t pix1, uint32_t pix2) { return ColorDistance::dist(pix1, pix2, cfg.luminanceWeight_) < cfg.equalColorTolerance_; };
|
||||
auto dist = [&](uint32_t pix1, uint32_t pix2) { return ColorDistance::dist(pix1, pix2, cfg.luminanceWeight_); };
|
||||
|
||||
- const bool doLineBlend = [&]() -> bool
|
||||
- {
|
||||
- if (getBottomR(blend) >= BLEND_DOMINANT)
|
||||
- return true;
|
||||
+ bool doLineBlend;
|
||||
|
||||
- //make sure there is no second blending in an adjacent rotation for this pixel: handles insular pixels, mario eyes
|
||||
- if (getTopR(blend) != BLEND_NONE && !eq(e, g)) //but support double-blending for 90° corners
|
||||
- return false;
|
||||
- if (getBottomL(blend) != BLEND_NONE && !eq(e, c))
|
||||
- return false;
|
||||
+ if (getBottomR(blend) >= BLEND_DOMINANT)
|
||||
+ doLineBlend = true;
|
||||
|
||||
- //no full blending for L-shapes; blend corner only (handles "mario mushroom eyes")
|
||||
- if (!eq(e, i) && eq(g, h) && eq(h , i) && eq(i, f) && eq(f, c))
|
||||
- return false;
|
||||
-
|
||||
- return true;
|
||||
- }();
|
||||
+ //make sure there is no second blending in an adjacent rotation for this pixel: handles insular pixels, mario eyes
|
||||
+ else if (getTopR(blend) != BLEND_NONE && !eq(e, g)) //but support double-blending for 90° corners
|
||||
+ doLineBlend = false;
|
||||
+ else if (getBottomL(blend) != BLEND_NONE && !eq(e, c))
|
||||
+ doLineBlend = false;
|
||||
+ //no full blending for L-shapes; blend corner only (handles "mario mushroom eyes")
|
||||
+ else if (!eq(e, i) && eq(g, h) && eq(h , i) && eq(i, f) && eq(f, c))
|
||||
+ doLineBlend = false;
|
||||
+ else
|
||||
+ doLineBlend = true;
|
||||
|
||||
const uint32_t px = dist(e, f) <= dist(e, h) ? f : h; //choose most similar color
|
||||
|
Loading…
Reference in New Issue
Block a user