FUCK YOU NETWORKMANAGER
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

PKGBUILD 3.0KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Maintainer: Alex Taber <aft dot pokemon at gmail dot com>
  2. pkgname=teamviewer
  3. pkgver=14.2.8352
  4. pkgrel=1
  5. pkgdesc='All-In-One Software for Remote Support and Online Meetings'
  6. arch=('i686' 'x86_64' 'armv7h')
  7. url='http://www.teamviewer.com'
  8. license=('custom')
  9. options=('!strip')
  10. provides=('teamviewer')
  11. conflicts=('teamviewer-beta')
  12. # /opt/teamviewer/tv_bin/script/teamviewer_setup checklibs can check deps for each TV component:
  13. # TV_DMN, TV_DESK, TV_GUI
  14. depends=(
  15. 'hicolor-icon-theme'
  16. 'qt5-webkit'
  17. 'qt5-x11extras'
  18. 'qt5-quickcontrols' # Doesn't appear in namcap, won't display UI without it.
  19. )
  20. #depends_x86_64=(
  21. # libdepends:
  22. # 'lib32-libxtst'
  23. # 'lib32-libxinerama'
  24. # 'lib32-libxrandr'
  25. # 'lib32-libxdamage'
  26. # 'lib32-fontconfig'
  27. # 'lib32-libsm')
  28. #depends_i686=()
  29. #depends_armv7h=()
  30. install=teamviewer.install
  31. source_x86_64=("https://dl.tvcdn.de/download/linux/version_${pkgver%%.*}x/teamviewer_${pkgver}_amd64.deb")
  32. source_i686=("https://dl.tvcdn.de/download/linux/version_${pkgver%%.*}x/teamviewer_${pkgver}_i386.deb")
  33. source_armv7h=("https://dl.tvcdn.de/download/linux/version_${pkgver%%.*}x/teamviewer-host_${pkgver}_armhf.deb")
  34. #source_armv7h=("https://dl.tvcdn.de/download/linux/version_${pkgver%%.*}x/teamviewer-host_13.2.13582_armhf.deb")
  35. sha256sums_i686=('23321131a51d65b7a594599ad6fc88cc8033381bfc7eed681d1209b14ebd157e')
  36. sha256sums_x86_64=('5e89849b45302c12b752ee99b9aaa48c0e8dde4f756d389d078b3cf3e8804e8c')
  37. sha256sums_armv7h=('e3f41879ad19ee28091f8293f3449c1b74af06e81423bba87574364df4963f61')
  38. prepare() {
  39. warning "If the install fails, you need to uninstall previous major version of Teamviewer"
  40. [ -d data ] && rm -rf data
  41. mkdir data
  42. cd data
  43. for datatar in ../data.tar.*; do
  44. msg2 "Unpacking $datatar"
  45. tar -xf $datatar
  46. done
  47. sed -i '/function CheckQtQuickControls()/{N;a ls /usr/lib/qt/qml/QtQuick/Controls/qmldir &>/dev/null && return # ArchLinux
  48. }' ./opt/teamviewer/tv_bin/script/teamviewer_setup || msg2 "Patching CheckQtQuickControls failed! Contact maintainer"
  49. msg2 "Running teamviewer_setup checklibs"
  50. ./opt/teamviewer/tv_bin/script/teamviewer_setup checklibs \
  51. || msg2 "teamviewer_setup checklibs failed, contact maintainer with /tmp/teamviewerTARLibCheck/DependencyCheck.log" # Currently it always exits 0
  52. }
  53. package() {
  54. # Install
  55. warning "If the install fails, you need to uninstall previous major version of Teamviewer"
  56. cp -dr --no-preserve=ownership ./data/{etc,opt,usr,var} "${pkgdir}"/
  57. # Additional files
  58. rm "${pkgdir}"/opt/teamviewer/tv_bin/xdg-utils/xdg-email
  59. rm -rf "${pkgdir}"/etc/apt
  60. install -D -m0644 "${pkgdir}"/opt/teamviewer/tv_bin/script/teamviewerd.service \
  61. "${pkgdir}"/usr/lib/systemd/system/teamviewerd.service
  62. install -d -m0755 "${pkgdir}"/usr/{share/applications,share/licenses/teamviewer}
  63. ln -s /opt/teamviewer/License.txt \
  64. "${pkgdir}"/usr/share/licenses/teamviewer/LICENSE
  65. if [ "$CARCH" = "x86_64" ] && [ -f "${pkgdir}/opt/teamviewer/tv_bin/script/libdepend" ]; then
  66. msg2 "Removing libdepend to ditch lib32 dependencies"
  67. rm "${pkgdir}/opt/teamviewer/tv_bin/script/libdepend"
  68. fi
  69. }